Настройка и добавление проекта в kscope

Материал из База знаний Etersoft
Перейти к: навигация, поиск

1. Настройка KScope

Для начала заходим в меню Settings -> Configure KScope. Выбираем вкладку Programmes, настраиваем пути (можно нажать на кнопку "Guess", которая находится чуть ниже).

  1. Cscope path: /usr/bin/cscope
  2. Cscope tags: /usr/bin/ctags
  3. Dot path: /usr/bin/dot

На своё усмотрение можно настроить цвета и шрифт в соответствующих вкладках Colours и Fonts.

2. Создание проекта

Заходим в меню Project -> New Project. И произведём такие настройки:

  1. Вкладка Details:

В поле "Name" вводим название своего проекта. В поле "Path" указываем путь/папку, в которой будет храниться файл вашего проекта. В поле "Source Root (Optional)" нужно указать путь к папке с теми файлами, которые вы хотите добавить в проект для редактирования, позже, при добавлении новых файлов, по умолчанию будет открываться именно эта папка.

  1. Вкладка File Types:

Здесь мы выбираем тип файлов (расширения), которые нужно добавить в проект. Выбираем в правой колонке нужный тип файла и нажимаем "<< Add", нужный нам тип появится в левой колонке. После того, как вы добавите все необходимые типы, нажмите на "Create".

3. Добавление файлов в проект

После того, как в описании выше вы нажмёте на "Create", откроется окно Project Files, которое также можно вызвать из меню "Projects -> Add/Remove Files". В этом окне можно добавлять файлы для редактирования кода.

В поле "Filter" можно задать фильтр для добавляемых файлов. Например, если у вас в папке есть файлы ".cpp" и ".h", то при указания фильтра ".h", в проект добавятся только файлы с этим расширением. Для того, чтобы добавить файлы, нужно кликнуть на любую из трёх кнопок:

  1. Files - просто добавляет в проект файлы из папки, можете сами выбрать нужные файлы
  2. Directory - вы кликаете на папку и в проект добавляются все файлы из папки
  3. Tree - в проект добавятся файлы из всего дерева

Если вы захотите, чтобы можно было добавить файлы с другим расширением, то вам нужно зайти в Project -> Properties, выбрать вкладку "File Types" и произвести уже знакомые вам действия.